View Issue Details

IDProjectCategoryView StatusLast Update
0003290KCleanerBugpublic2015-11-14 12:38
ReporterpeterblaiseAssigned ToKyle_Katarn 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Platformintel/AMDOSWindowsOS Version7 64
Product Version1.2.3 
Target VersionFixed in Version2.6.2 
Summary0003290: Unexpected file selection for deletion
Descriptionselects entire harddrive contents as cookies to be removed, if you don't notice, erases all files not in use
Steps To Reproducerandom
Additional InformationI just don't like v2, it hides too much information on what it's doing.
TagsNo tags attached.

Relationships

related to 0001130 resolvedKyle_Katarn KCleaner shall reject empty "system" folder returned by API 

Activities

peterblaise

2015-11-10 02:01

reporter  

Kyle_Katarn

2015-11-10 22:02

administrator   ~0002145

Please post logs.
Does problems occurs with v2.0 too ?
v2.0 does not show less info ! (simply click on "expert" mode)

peterblaise

2015-11-11 07:21

reporter   ~0002146

I don't use v2 because it does not show results of deletion before exit as v1 does, and so, I don't know what v2 actually did.

After trashing one drive, I now watch carefully, and if it starts to take a l-o-n-g time and only finds "cookies" even though I see EXE files, I exit and reboot.

I found v1.3.0.47 on a Russian site, apparently the last v1 -- why no archives at your own site?

Kyle_Katarn

2015-11-11 20:25

administrator   ~0002147

Unable to reproduce, but i'll had some "defensive" programming in next release.

v2 does the same 2 step approach that v1 :
- switch to "Expert mode"
- use "Simulate" before going to "clean"

peterblaise

2015-11-14 00:34

reporter   ~0002149

Last edited: 2015-11-14 12:38

View 2 revisions

Yes, "selects entire hard drive as cookies" happens in latest KCleaner v2.6.1.63, also, so, NEVER run in auto mode, TEST first, reboot if problem presents itself, try again, see [ Simulate ] results here: http://oi68.tinypic.com/1zyatnc.jpg

Kyle_Katarn

2015-11-14 12:37

administrator  

1zyatnc.jpg (125,083 bytes)
1zyatnc.jpg (125,083 bytes)

Kyle_Katarn

2015-11-14 12:38

administrator   ~0002150

Please check with 2.6.2 and attach logs if problem persists.

Issue History

Date Modified Username Field Change
2015-11-10 02:01 peterblaise New Issue
2015-11-10 02:01 peterblaise File Added: kcleaner-gone-wild-2015-11-06.jpg
2015-11-10 22:02 Kyle_Katarn Note Added: 0002145
2015-11-10 22:02 Kyle_Katarn Assigned To => Kyle_Katarn
2015-11-10 22:02 Kyle_Katarn Status new => feedback
2015-11-11 07:21 peterblaise Note Added: 0002146
2015-11-11 20:23 Kyle_Katarn Relationship added related to 0001130
2015-11-11 20:25 Kyle_Katarn Note Added: 0002147
2015-11-11 20:25 Kyle_Katarn Status feedback => resolved
2015-11-11 20:25 Kyle_Katarn Fixed in Version => 2.6.2
2015-11-11 20:25 Kyle_Katarn Resolution open => fixed
2015-11-11 20:41 Kyle_Katarn Summary selects entire harddrive contents as cookies to be removed, if you don't notice, erases all files not in use => Unexpected file selection for deletion
2015-11-14 00:34 peterblaise Note Added: 0002149
2015-11-14 00:34 peterblaise Status resolved => feedback
2015-11-14 00:34 peterblaise Resolution fixed => reopened
2015-11-14 12:37 Kyle_Katarn File Added: 1zyatnc.jpg
2015-11-14 12:38 Kyle_Katarn Status feedback => resolved
2015-11-14 12:38 Kyle_Katarn Resolution reopened => fixed
2015-11-14 12:38 Kyle_Katarn Note Edited: 0002149 View Revisions
2015-11-14 12:38 Kyle_Katarn Note Added: 0002150