View Issue Details

IDProjectCategoryView StatusLast Update
0004677SUMoRefactoringpublic2021-02-07 16:16
ReporterOLLI_S Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSMicrosoft WindowsOS Version10
Product Version5.5.1 
Target Version5.12.5Fixed in Version5.12.5 
Summary0004677: ArtMoney not properly detcted
DescriptionThe application "ArtMoney" is not properly detected by SUMo.
ArtMoney is an application to search in memory of games for values and change them (cheat the games).
Some games try to detect ArtMoney, so the application is trying to "hide" itself (by having not many information in the properties of the EXE file).

For "ArtMoney" version 8.00 SUMo detects:
Product: am800 (64 bits)
Company:
Version: 1.0.0.0
File Path: C:\Games\ArtMoney\am800.exe

I downloaded the update to version 8.01 today and SUMo detects:
Product: am801 (64 bits)
Company:
Version: 1.0.0.0
File Path: C:\Games\ArtMoney\am801.exe

SUMo does also not tetect if it is "ArtMoney" or "ArtMoney Pro".
I have ArtMoney Pro.

Download site of ArtMoney: http://artmoney.ru/e_download.htm
There are separate download-sites for each version, so if you can detect that I have "ArtMoney Pro" then you should open: http://artmoney.ru/e_download_pro.htm
TagsNo tags attached.

Activities

OLLI_S

2018-01-14 17:20

reporter  

ArtMoney_8.01_Properties.png (24,983 bytes)   
ArtMoney_8.01_Properties.png (24,983 bytes)   

Kyle_Katarn

2018-01-14 17:42

administrator   ~0002773

Then i'd suggest to have it reported to its developper. Do you agree ?

OLLI_S

2018-01-14 17:55

reporter   ~0002774

No, because I already did this and received the following answer:
> Anti-Cheat can detect ArtMoney too. We don't want it.

So the only information you have for sure is the name of the exe file and the file size.
I suggest that you add these criteria to detect ArtMoney.

By the way: the company is "System SoftLab"

Kyle_Katarn

2018-01-14 18:11

administrator   ~0002775

OK, i'll check this. Low priority (too specific) but why not :)

OLLI_S

2018-01-14 18:21

reporter   ~0002776

Thank you

OLLI_S

2018-03-18 13:21

reporter   ~0002811

This issue has the status "feedback", so what feedback do you need?

In SUMo 5.5.7.388 SUMo detects:
Product: am801 (64 bits)
Company:
Version: 1.0.0.0
File Path: C:\Games\ArtMoney\am801.exe

Would be great if you would show:
Product: ArtMoney (64 bits)
Company: System SoftLab
Version: 8.01
File Path: C:\Games\ArtMoney\am801.exe

Kyle_Katarn

2021-02-07 16:16

administrator   ~0004161

3 years old bug fix / feature request now solved ! Thanks for your patience

Issue History

Date Modified Username Field Change
2018-01-14 17:20 OLLI_S New Issue
2018-01-14 17:20 OLLI_S File Added: ArtMoney_8.01_Properties.png
2018-01-14 17:42 Kyle_Katarn Assigned To => Kyle_Katarn
2018-01-14 17:42 Kyle_Katarn Status new => feedback
2018-01-14 17:42 Kyle_Katarn Note Added: 0002773
2018-01-14 17:55 OLLI_S Note Added: 0002774
2018-01-14 18:11 Kyle_Katarn Note Added: 0002775
2018-01-14 18:21 OLLI_S Note Added: 0002776
2018-03-18 13:21 OLLI_S Note Added: 0002811
2020-11-14 21:29 Kyle_Katarn Status feedback => acknowledged
2020-11-14 21:29 Kyle_Katarn Target Version => 5.12
2020-11-14 21:29 Kyle_Katarn Description Updated
2020-12-19 11:08 Kyle_Katarn Target Version 5.12 => 5.12.1
2020-12-26 11:59 Kyle_Katarn Target Version 5.12.1 => 5.12.2
2021-01-03 13:44 Kyle_Katarn Target Version 5.12.2 => 5.12.3
2021-01-16 13:43 Kyle_Katarn Target Version 5.12.3 => 5.12.4
2021-01-30 15:42 Kyle_Katarn Target Version 5.12.4 => 5.12.5
2021-02-07 16:11 Kyle_Katarn Status acknowledged => resolved
2021-02-07 16:11 Kyle_Katarn Resolution open => fixed
2021-02-07 16:11 Kyle_Katarn Fixed in Version => 5.12.5
2021-02-07 16:16 Kyle_Katarn Note Added: 0004161