View Issue Details

IDProjectCategoryView StatusLast Update
0005457SUMoBugpublic2019-05-04 11:39
ReporterwolfAssigned ToKyle_Katarn 
PrioritynormalSeveritytextReproducibilityrandom
Status resolvedResolutionfixed 
Product Version5.9 
Target Version5.9.1Fixed in Version5.9.1 
Summary0005457: SUMo Online German translation and language errors in client user interface
DescriptionWhen I updated SUMo of version 5.9.0.415 to 5.9.0.420, the user interface had some language problems. Although I configured the user interface to use the German language, it did so except for the new feature SUMo Online which was entirely English!

As I'm fluent in three languages, I just switched among them and saw even further translation errors in all three languages and side effects. In contrast to the moment of updating, the installed menu changed the language of the interface even further, now presenting a mix of languages, regardless which language I configure in options. The French menu includes English terms. The German menu includes now not only English and German but also French terms in several windows, see attached screenshots! Why isn't this deterministic any more?

Now, SUMo displays one menu line and one button label in French although it did display it in English on the moment of updating SUMo and should display them in German as configured!

The first menu line is named "Configure...". It should be named "Konfiguriere ..." resp. "Konfiguration ..." instead in German.

BTW, I couldn't find your translation nor language policy. Do you have one?
(It doesn't seem so.)
When do you want to use verbs and when nouns?
In many programs, I see nouns used in preference to verbs. That should be easy to change into nouns in all languages I know. For the above sample, the first variant is a verb and the second a noun.

The second menu line was named "View Dashboard..." and is now called "Voir le tableau de bord...". It should be named "Dashboard" resp. "Betrachte Dashboard" instead in German. The first variant is the noun and the second the activity with verb.

With the SUMo Online configuration window, that's the same mixture and behaviour.
The first line is named "Enable SUMo Online". It should be labeled either "SUMo Online" (noun) or "Aktiviere SUMo Online" (verb).
The second line can almost remain. In German, the same term is used. The error is white space. As implemented already and correctly in options, there should be no white space before the colon. It shoudl read "Login:" instead of "Login :". Another possibility for the German translation would be "Benutzername:".
In the third line, I don't understand yet the label of the button currently named "Test". According to my understanding, it should be called "SUMo Online Initialization" in case of noun resp. "Initialize SUMo Online" in case of verb in English. The corresponding German translation is "SUMo Online Initialisierung" in case of noun and "initialisiere SUMo Online" in case of verb.
I guess the fourth line needs to be redesigned and split into two actions, see another bug report (https://www.kcsoftwares.com/bugs/view.php?id=5379). As it is, it should be renamed "Create New Account" as verb/activity resp. "New Account Creation" as noun. In German, that's "Lege Neuen Benutzer an" as activity resp. "Neuer Benutzer" as short noun or "Neuer Benutzername" or "Neuanlage Benutzername" or "Neueröffnung Benutzerkonto" as alternative noun translations. The last variant fits best on one side and has ambiguity due to several meanings on the other side and hence should not be chosen as translation.
The last line has been named "Close" on update and now "Fermer". It should remain "Close" in English. The German translation may be "Schließen" or "Fenster Schließen" as activity/verb resp. "Zurück" (meaning "back") or "Ende" (meaning "end") otherwise.
Tagslanguage

Relationships

related to 0005460 resolvedKyle_Katarn Updated Germand translation 

Activities

wolf

2019-05-04 03:23

reporter  

Issue History

Date Modified Username Field Change
2019-05-04 03:23 wolf New Issue
2019-05-04 03:23 wolf File Added: sumo.online.lang.20190504.png
2019-05-04 03:23 wolf File Added: sumo.online.cfg.lang.20190504.png
2019-05-04 03:24 wolf Tag Attached: language
2019-05-04 09:12 Kyle_Katarn Assigned To => Kyle_Katarn
2019-05-04 09:12 Kyle_Katarn Status new => acknowledged
2019-05-04 09:12 Kyle_Katarn Target Version => 5.9.1
2019-05-04 11:39 Kyle_Katarn Relationship added related to 0005460
2019-05-04 11:39 Kyle_Katarn Status acknowledged => resolved
2019-05-04 11:39 Kyle_Katarn Resolution open => fixed
2019-05-04 11:39 Kyle_Katarn Fixed in Version => 5.9.1