View Issue Details

IDProjectCategoryView StatusLast Update
0005461SUMoBugpublic2019-05-08 11:45
ReporterwolfAssigned ToKyle_Katarn 
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0005461: MantisBT report mismatch of # of unassigned issues due to inconsistent non-complying use of the tool in only a few listed issues
DescriptionHere, I'm reporting not a bug in the application nor in the tool MantisBT although at first glance it might look like the latter. The root cause seems to be KC Softwares' inconsistent use of this tool MantisBT. And this phenomen is not wide spread, looks more like unintended or by accident.

Observation:
If you go to overview within MantisBT, you'll see a section showing up to 10 unassigned issues reporting also the number of all unassigned issues and an action button to show all these unassigned ones. Currently, it shows me 10 issues unassigned, reporting me that 45 are unassigned. If I request MantisBT to show me all those unassigned issues as proposed, the resulting report shows me 50 unassigned issues, not reported 45.

I didn't try a deeper analysis as it seems that there are TWO root causes. I couldn't verify because I don't have the permissions to probably fix it. If I'm right, the fix may be performed quickly.

The first root cause seems to be different filter configurations in the overview view and in the report all of them view. I prefer that this filter configuration mismatch (issues in which state to ignore) does not get fixed as it does only fix reporting inconsistency and would hide the deeper root cause.
This second root cause is a mismatch in the issues. According to your not-communicated state model of use of MantisBT, an issue has to comply with certain criteria depending on the state of an issue. The cause of this reporting mismatch seems to be a non-compliance in currently 5 cases in state RESOLVED. In these issues, the assignment attribute is empty instead of usually being assigned to the user which confirmed the issue resolved. Here is the list of issues concerned:
* https://www.kcsoftwares.com/bugs/view.php?id=3016
* https://www.kcsoftwares.com/bugs/view.php?id=2134
* https://www.kcsoftwares.com/bugs/view.php?id=2133
* https://www.kcsoftwares.com/bugs/view.php?id=2132
* https://www.kcsoftwares.com/bugs/view.php?id=2164
Steps To ReproduceAs stated above, go into the overview view of MantisBT and then click on the Show all issues of the section of unassigned issues.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-05-04 11:49 wolf New Issue
2019-05-08 11:45 Kyle_Katarn Assigned To => Kyle_Katarn
2019-05-08 11:45 Kyle_Katarn Status new => resolved
2019-05-08 11:45 Kyle_Katarn Resolution open => fixed