View Issue Details

IDProjectCategoryView StatusLast Update
0005534DUMoBugpublic2019-06-10 21:51
Reporterwolf Assigned ToKyle_Katarn  
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionreopened 
Product Version2.17.5 
Target Version2.18Fixed in Version2.18 
Summary0005534: DUMo Portable with SUMo license ?
DescriptionDUMo Portable of PortableApps-Framework has been updated. On Update it displays the KC Softwares SUMo license. What's the relation to DUMo Portable to SUMo license?

Shouldn't the license being renamed to KC Softwares portable license, without any product name?
The same license is used for KCleaner Portable of PortableApps-Framework.

And DUMo Portable has the software update button. If on the computer accidently SUMo is installed, it seems that click on that DUMo button starts SUMo instead of SUMo Portable.
TagsNo tags attached.

Relationships

related to 0005537 resolvedKyle_Katarn DUMo DUMo with SUMo license ? 
related to 0005535 closedKyle_Katarn KCleaner KCleaner Portable with SUMo license ? 

Activities

wolf

2019-06-05 12:42

reporter  

Kyle_Katarn

2019-06-05 20:45

administrator   ~0003446

Looks like a PortableApps bug, not affecting our installers. Do you confirm ?
If yes, i'll close and i'll report to PA

wolf

2019-06-06 01:24

reporter   ~0003449

I don't know the source of that license. It's definitely no PortableApps license. I don't know which license text you agreed with PortableApps. I don't remember such a license text when installing DUMo (classical). So I can't neither confirm nor deny and hence the order of proposed action seems to be inappropriate.
First report to PA and clarify source of text how it gets integrated including responsibility. Propose corresponding text change if it's their interpretation of the license provided by you. Best practice is then to await fix in PA before closing. I agree and confirm that I see this license text when KC Softwares portable edition gets updated in PA context with PA means. So beside clarification and awaiting fix I guess no further action needed on KC Softwares side. And I guess that PA will not fix this integration before next release of DUMo.

I emphasize that this issue describes not only the license text aspect but also the functionality. I didn't test with portable edition of DUMo and SUMo of KC Softwares as those editions found in PA framework if they have the same bug of referring to installed edition instead of portable edition. If the portable editions of KC Softwares don't show the same symptom then it seems to be an integration issue of PA. Otherwise it's a bug already in the KC Softwares portable edition.

Kyle_Katarn

2019-06-06 20:57

administrator   ~0003453

Problem is clearly not ok our site. I'll report the problem to PA.

Kyle_Katarn

2019-06-06 20:59

administrator   ~0003454

https://portableapps.com/node/60470

wolf

2019-06-08 10:28

reporter   ~0003456

It seems that its not just an integration error on the side of PortableApps team but also an issue of KC Softwares itself. See related issue https://www.kcsoftwares.com/bugs/view.php?id=5537 as the license text of DUMo is named SUMo license!

Kyle_Katarn

2019-06-08 10:43

administrator   ~0003459

Confirmed !

Issue History

Date Modified Username Field Change
2019-06-05 12:42 wolf New Issue
2019-06-05 12:42 wolf File Added: dumo.port.license.20190605.png
2019-06-05 20:43 Kyle_Katarn Relationship added related to 0005535
2019-06-05 20:45 Kyle_Katarn Assigned To => Kyle_Katarn
2019-06-05 20:45 Kyle_Katarn Status new => feedback
2019-06-05 20:45 Kyle_Katarn Note Added: 0003446
2019-06-06 01:24 wolf Note Added: 0003449
2019-06-06 20:57 Kyle_Katarn Note Added: 0003453
2019-06-06 20:57 Kyle_Katarn Status feedback => closed
2019-06-06 20:57 Kyle_Katarn Resolution open => no change required
2019-06-06 20:59 Kyle_Katarn Note Added: 0003454
2019-06-08 10:28 wolf Status closed => feedback
2019-06-08 10:28 wolf Resolution no change required => reopened
2019-06-08 10:28 wolf Note Added: 0003456
2019-06-08 10:43 Kyle_Katarn Status feedback => acknowledged
2019-06-08 10:43 Kyle_Katarn Note Added: 0003459
2019-06-08 10:43 Kyle_Katarn Relationship added related to 0005537
2019-06-08 10:43 Kyle_Katarn Target Version => 2.18
2019-06-10 21:51 Kyle_Katarn Status acknowledged => resolved
2019-06-10 21:51 Kyle_Katarn Fixed in Version => 2.18