View Issue Details

IDProjectCategoryView StatusLast Update
0000062PhotoToFilmBugpublic2006-03-16 23:21
Reporterhannibalstgt Assigned ToKyle_Katarn  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows XP HomeOS Version2002 SP 2
Product Version 
Target VersionFixed in Version2.5.1 
Summary0000062: Sound still does not match
DescriptionSoundfile lenght 73 second, number of provided images 30, no options
Codec DivX 6.1.1 (unrestricted) and MP42 (Microsoft MPEG-4 V2)
(actually the program took the options away) - stick to that, because options make things more difficult - can be taken into consideration when base problem is solved.

Expected duration of on image is 73000 / 30 = 2433 milliseconds
shown (after match to sound) is 73000 / 33 = 2212 milliseconds
that seems, the wrong image count is used to calculate the duration.

Generation works with both Codecs - so the problem is Codec independent.
After generation no "DONE" window apppears. Processing just stops without completion message.

What happens if generated file played back:

If played back with DivX player the movie seems to be OK - that is it plays for 67 seconds (if not taken in account that the sound is slightly longer than the movie - probably rounding problems - not that important).

If played back with Windows Media Player:

Actual duration of playback is 94 seconds - expected are 73 seconds,
file shows a length of 67 (or 66) seconds.
The progress bar pauses at position 16 seconds, 26 seconds and 35 seconds for about 8 seconds (this are the times which are shown by the player, but the positions are actually at about 22 sec, 35 sec, and 47 seconds - because the movie is expanded to 94 seconds, that means the playback is stretched by the factor of a little more than 1.3).
The sound ends after about 47 seconds ( = displayed time, but actually exactly after 73 seconds if measured with the stopwatch)




TagsNo tags attached.

Activities

hannibalstgt

2006-03-08 09:37

reporter   ~0000063

Additional information:
the problem is independent of the used fps value.
Used 15 fps and 25 fps.

In both cases exactly the same results.

hannibalstgt

2006-03-08 16:16

reporter   ~0000069

Last edited: 2006-03-08 16:17

The BSPlayer shows exactly the same behaviour as the Windows Media Player
(real lenght 93 seconds, sound stops at 73st second - 46 sec presented, pauses for about 8 seconds at position 16, 26 and 36 - presented value - not measured value).

This is still with the file built with version 2.4.060.

BUT: no change with build 61 - exactly the same behaviour of BSPlayer

hannibalstgt

2006-03-08 16:21

reporter   ~0000070

Preseted image time still wrong

Kyle_Katarn

2006-03-08 18:06

administrator   ~0000072

Match to sound fixed in build 62 and later.

Sound+freeze bug (other issue) not fixed

Issue History

Date Modified Username Field Change
2006-03-08 09:34 hannibalstgt New Issue
2006-03-08 09:34 hannibalstgt File Added: Build60_01_StandardTest.jpg
2006-03-08 09:37 hannibalstgt Note Added: 0000063
2006-03-08 10:59 Kyle_Katarn Assigned To => Kyle_Katarn
2006-03-08 10:59 Kyle_Katarn Status new => acknowledged
2006-03-08 16:16 hannibalstgt Note Added: 0000069
2006-03-08 16:17 hannibalstgt File Added: Build61_01_StandardTest.jpg
2006-03-08 16:17 hannibalstgt File Added: BSPlayerShot.jpg
2006-03-08 16:17 hannibalstgt Note Edited: 0000069
2006-03-08 16:18 hannibalstgt File Added: DivXProfile.jpg
2006-03-08 16:21 hannibalstgt Note Added: 0000070
2006-03-08 18:06 Kyle_Katarn Status acknowledged => resolved
2006-03-08 18:06 Kyle_Katarn Resolution open => fixed
2006-03-08 18:06 Kyle_Katarn Note Added: 0000072
2006-03-16 12:06 Kyle_Katarn Status resolved => new
2006-03-16 12:06 Kyle_Katarn Status new => resolved
2006-03-16 12:06 Kyle_Katarn Fixed in Version => 2.5.1
2006-03-16 23:21 Kyle_Katarn Category => Bug