View Issue Details

IDProjectCategoryView StatusLast Update
0006316SUMoBugpublic2021-01-25 23:15
Reporterbhenshaw Assigned ToKyle_Katarn  
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionno change required 
Product Version5.12.2 
Summary0006316: error on website when using Get Update
DescriptionI have started in the last few days to get an error when I use Get Update. When it tries to take me the site to list the versions for that software I get an error message from Google Chrome (see attached). This doesn't happen every time, but it happens often enough to be annoying. I am using the latest version of SUMo and Google Chrome.

Bill
TagsNo tags attached.

Relationships

related to 0006313 closedKyle_Katarn Get Update not showing users version anymore 

Activities

bhenshaw

2021-01-15 07:02

reporter  

image1.jpg (21,575 bytes)   
image1.jpg (21,575 bytes)   

bhenshaw

2021-01-15 07:07

reporter   ~0004125

It looks like sometimes Get Update takes me to a kcsoftwares.com... website and sometimes kc-softwares.com and the error happens when it takes me to kc-softwares.com.

kcsoftware.com is flagged as secure and kc-softwares.com is flagged as not secure. kcsoftware.com is an https site while kc-software.com is not.

Should it be sending me to kc-software.com or is this an error of some sort? If kc-softare.com is the correct site, then it needs to be an https site.

Bill

bhenshaw

2021-01-15 07:09

reporter   ~0004126

I meant kcsoftwares.com and kc-softwares.com above. I sometimes misspelled it. There is no edit capability on the forum so I couldn't correct my mistakes.

Kyle_Katarn

2021-01-15 18:48

administrator   ~0004130

kc-softwares.com is our backup server. This is "as per design" when SUMo detects that alternate server is faster than the main one (due to overload).
We are working on this.
Appart from the Chrome popup, any functionnal issue ?

bhenshaw

2021-01-15 18:52

reporter   ~0004132

No, it seems to work correctly after I dismiss the pop-up.

Kyle_Katarn

2021-01-15 18:53

administrator   ~0004133

Then I'll keep design as it is and this should be "fixed" with performance improvement on server side (ongoing work)

bhenshaw

2021-01-15 18:58

reporter   ~0004134

I thought there was no functional issue, but maybe this is what is causing my other issue (633) where it doesn't always say what version I am on. I just did a Get Update and it took me to kc-softwares.com and it isn't showing what version I'm on.
image2.jpg (74,688 bytes)   
image2.jpg (74,688 bytes)   

bhenshaw

2021-01-15 18:59

reporter   ~0004135

I meant 6313. Sure would be nice to have an edit function so we could edit our own posts.

Kyle_Katarn

2021-01-15 19:02

administrator   ~0004136

That's certainly the cause for 0006313 (eg partial check done on Main server while Alternate server opens when looking for upate)

bhenshaw

2021-01-15 19:07

reporter   ~0004137

Well, I'm glad we were able to figure out what was causing the 6313 problem.

Until you get the server performance issues figured out, it would be nice if kc-software.com was an https site.

Bill

bhenshaw

2021-01-15 19:10

reporter   ~0004138

Again, maybe I spoke to fast. I tried Get Update again, it took me to kcsoftwares.com and does not show what version I'm on.

Bill
image3.jpg (86,649 bytes)   
image3.jpg (86,649 bytes)   

Kyle_Katarn

2021-01-16 10:45

administrator   ~0004143

Yes, but was last "check" on kcsoftwares.com or kc-softwares.com ? to be checked in your last log after right click > Check on the given product.

bhenshaw

2021-01-16 19:11

reporter   ~0004145

I didn't do a right click > check... I selected the program and then did Get Update.

Sorry Kyle, I don't see the server information. I turned on debug mode, selected SUMo, and did a Get Update. The URL shown on the resulting page was https://www.kcsoftwares.com/sumo/view.php?uid=292743612&ProductName=SUMo&Company=KC%20Softwares&prot=2&pro. The page did not indicate what version I am on. I have attached the log.

Bill
SUMo.log (5,372 bytes)   
Info	[21-01-16 10:03:01]	Closing SUMo
Info	[21-01-16 10:03:01]	Writing Stats
Info	[21-01-16 10:02:27]	Alt Server Online (422 ms)
Info	[21-01-16 10:02:27]	Main Server Online (391 ms)
Info	[21-01-16 10:02:26]	Alt Server Status Query
Info	[21-01-16 10:02:26]	Main Server Status Query
Info	[21-01-16 10:01:36]	Startup phase done
Info	[21-01-16 10:01:36]	SUMo is already up to date.
Info	[21-01-16 10:01:36]	Auto Check disabled in settings
Info	[21-01-16 10:01:36]	Loading finished : 49 / 49 items loaded
Info	[21-01-16 10:01:36]	Creating database backup
Info	[21-01-16 10:01:36]	Loading... Done.
Info	[21-01-16 10:01:36]	Removing useless skipped items... Done.
Info	[21-01-16 10:01:36]	Removing useless skipped items...
Info	[21-01-16 10:01:36]	Filtering duplicate items... Done.
Info	[21-01-16 10:01:35]	Filtering duplicate items
Info	[21-01-16 10:01:35]	Removing unnecessary files... Done.
Info	[21-01-16 10:01:35]	Removing unnecessary files
Info	[21-01-16 10:01:34]	Loading...
Info	[21-01-16 10:01:34]	Reload required.
Info	[21-01-16 10:01:34]	Scanning Java... (C:\Program Files\Java\)
Info	[21-01-16 10:01:34]	Scanning Java... (C:\Program Files (x86)\Java\)
Info	[21-01-16 10:01:34]	Scanning Shockwave... (C:\Windows\System32)
Info	[21-01-16 10:01:34]	Scanning AIR... (C:\Program Files\Common Files\Adobe AIR\Versions\)
Info	[21-01-16 10:01:34]	Scanning AIR... (C:\Program Files (x86)\Common Files\Adobe AIR\Versions\)
Info	[21-01-16 10:01:34]	Scanning Flash (C:\Windows\SysWOW64\Macromed\Flash\)
Info	[21-01-16 10:01:34]	Scanning Flash (C:\Windows\SysWOW64\Macromed\Flash\)
Info	[21-01-16 10:01:34]	Scanning Flash (C:\Windows\System32\Macromed\Flash\)
Info	[21-01-16 10:01:34]	Scanning Flash (C:\Windows\System32\Macromed\Flash\)
Info	[21-01-16 10:01:33]	Scanning Registry... 
Info	[21-01-16 10:01:29]	Scanning Custom (D:\My Documents)
Info	[21-01-16 10:01:29]	Scanning QuickLaunch (C:\Users\wrhen\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\)
Info	[21-01-16 10:01:29]	Scanning Desktop Common (C:\Users\Public\Desktop)
Info	[21-01-16 10:01:29]	Scanning Desktop (C:\Users\wrhen\Desktop)
Info	[21-01-16 10:01:29]	Scanning Start Menu Common (C:\ProgramData\Microsoft\Windows\Start Menu)
Info	[21-01-16 10:01:29]	Scanning Start Menu (C:\Users\wrhen\AppData\Roaming\Microsoft\Windows\Start Menu)
Info	[21-01-16 10:01:28]	SUMo Update self check : Server replied 5.12.3.475 in 1734ms
Info	[21-01-16 10:01:28]	Licence checked OK
Info	[21-01-16 10:01:28]	File downloaded in 1500ms
Info	[21-01-16 10:01:28]	Scanning Screensavers
Info	[21-01-16 10:01:26]	Scanning Screensavers
Info	[21-01-16 10:01:26]	Scanning (heavy)...
Info	[21-01-16 10:01:26]	Checking licence... (Alternate)
Info	[21-01-16 10:01:26]	Auto Scan...
Info	[21-01-16 10:01:26]	Alt Server Online (422 ms)
Info	[21-01-16 10:01:26]	SUMo Update self check : Initialization
Info	[21-01-16 10:01:26]	Self update check...
Info	[21-01-16 10:01:26]	Main Server Online (406 ms)
Info	[21-01-16 10:01:26]	Alt Server Status Query
Info	[21-01-16 10:01:26]	Main Server Status Query
Info	[21-01-16 10:01:25]	Licence checked OK
Info	[21-01-16 10:01:25]	File downloaded in 1563ms
Info	[21-01-16 10:01:25]	Loading finished : 49 / 49 items loaded
Info	[21-01-16 10:01:25]	Creating database backup
Info	[21-01-16 10:01:25]	Loading... Done.
Info	[21-01-16 10:01:25]	Removing useless skipped items... Done.
Info	[21-01-16 10:01:25]	Removing useless skipped items...
Info	[21-01-16 10:01:25]	Filtering duplicate items... Done.
Info	[21-01-16 10:01:25]	Filtering duplicate items
Info	[21-01-16 10:01:25]	Removing unnecessary files... Done.
Info	[21-01-16 10:01:25]	Removing unnecessary files
Info	[21-01-16 10:01:24]	Loading...
Info	[21-01-16 10:01:24]	Scanning Java... (C:\Program Files\Java\)
Info	[21-01-16 10:01:24]	Scanning Java... (C:\Program Files (x86)\Java\)
Info	[21-01-16 10:01:24]	Scanning Shockwave... (C:\Windows\System32)
Info	[21-01-16 10:01:24]	Scanning AIR... (C:\Program Files\Common Files\Adobe AIR\Versions\)
Info	[21-01-16 10:01:24]	Scanning AIR... (C:\Program Files (x86)\Common Files\Adobe AIR\Versions\)
Info	[21-01-16 10:01:24]	Scanning Flash (C:\Windows\SysWOW64\Macromed\Flash\)
Info	[21-01-16 10:01:24]	Scanning Flash (C:\Windows\SysWOW64\Macromed\Flash\)
Info	[21-01-16 10:01:23]	Scanning Flash (C:\Windows\System32\Macromed\Flash\)
Info	[21-01-16 10:01:23]	Scanning Flash (C:\Windows\System32\Macromed\Flash\)
Info	[21-01-16 10:01:23]	Scanning (light)...
Info	[21-01-16 10:01:23]	DB list : 49 items
Info	[21-01-16 10:01:23]	Excluded folders list : 4 items
Info	[21-01-16 10:01:23]	Ignore list : 27 items
Info	[21-01-16 10:01:23]	Loading Skipped updates : 0 items
Info	[21-01-16 10:01:23]	Loading Cache : 1 items
Info	[21-01-16 10:01:23]	Checking licence... (Alternate)
Info	[21-01-16 10:01:23]	Direct Update : No
Info	[21-01-16 10:01:23]	Reading Stats
Info	[21-01-16 10:01:23]	Registered to Henshaw
Info	[21-01-16 10:01:23]	Language : English (United States)
Info	[21-01-16 10:01:23]	Portable : No
Info	[21-01-16 10:01:23]	Administrator : No
Info	[21-01-16 10:01:23]	64Bits : Yes
Info	[21-01-16 10:01:23]	Windows : 10.0 (Windows10)
Info	[21-01-16 10:01:23]	SUMo (Software Update Monitor) v5.12.3.475
Info	[21-01-16 10:01:23]	C:\Program Files (x86)\KC Softwares\SUMo\SUMo.exe
Info	[21-01-16 10:01:23]	Starting
SUMo.log (5,372 bytes)   

bhenshaw

2021-01-25 22:54

reporter   ~0004152

I am no longer seeing this error since the server issues and fix. I only see this error now when I mark a version of a program as beta. It is when marking the program as beta takes me to kc-softwares.com. Chrome pops up the error because kc-sofwtares.com is not a secure site.

Bill
image1-2.jpg (18,960 bytes)   
image1-2.jpg (18,960 bytes)   

Issue History

Date Modified Username Field Change
2021-01-15 07:02 bhenshaw New Issue
2021-01-15 07:02 bhenshaw File Added: image1.jpg
2021-01-15 07:07 bhenshaw Note Added: 0004125
2021-01-15 07:09 bhenshaw Note Added: 0004126
2021-01-15 18:48 Kyle_Katarn Assigned To => Kyle_Katarn
2021-01-15 18:48 Kyle_Katarn Status new => feedback
2021-01-15 18:48 Kyle_Katarn Note Added: 0004130
2021-01-15 18:52 bhenshaw Note Added: 0004132
2021-01-15 18:53 Kyle_Katarn Note Added: 0004133
2021-01-15 18:58 bhenshaw Note Added: 0004134
2021-01-15 18:58 bhenshaw File Added: image2.jpg
2021-01-15 18:59 bhenshaw Note Added: 0004135
2021-01-15 19:01 Kyle_Katarn Relationship added related to 0006313
2021-01-15 19:02 Kyle_Katarn Note Added: 0004136
2021-01-15 19:07 bhenshaw Note Added: 0004137
2021-01-15 19:10 bhenshaw Note Added: 0004138
2021-01-15 19:10 bhenshaw File Added: image3.jpg
2021-01-16 10:45 Kyle_Katarn Note Added: 0004143
2021-01-16 19:11 bhenshaw Note Added: 0004145
2021-01-16 19:11 bhenshaw File Added: SUMo.log
2021-01-25 22:54 bhenshaw Note Added: 0004152
2021-01-25 22:54 bhenshaw File Added: image1-2.jpg
2021-01-25 23:15 Kyle_Katarn Status feedback => closed
2021-01-25 23:15 Kyle_Katarn Resolution open => no change required