[Resolved] SUMo doesn't add programs in folders with 'Installer' in their name

Post Reply
ilike2burnthing
Posts: 23
Joined: Fri Dec 13, 2019 4:44 pm

[Resolved] SUMo doesn't add programs in folders with 'Installer' in their name

Post by ilike2burnthing »

I've tried this with a 4TB external HDD and a 64GB flash drive.

SUMo shows the folders being scanned, but then doesn't display any of the programs.

The workaround I've been using for a while now has been to symlink (mklink /j) the needed folders on the USB drive into %AppData%\KC Softwares\SUMo and then add \SUMo as an Additional Folder. Works for me, but I'm guessing it's not intended usage.

Is this a known issue?

Thanks!
Last edited by ilike2burnthing on Fri Apr 24, 2020 11:03 pm, edited 1 time in total.

Kyle_Katarn
Site Admin
Posts: 1411
Joined: Sun Jul 03, 2011 8:13 pm

Re: SUMo doesn't add programs in Additional Folders if they're on external USB drives

Post by Kyle_Katarn »

Please contact our Tech support ( contact @ kcsoftwares.com ) with SUMo logs.

ilike2burnthing
Posts: 23
Joined: Fri Dec 13, 2019 4:44 pm

Re: SUMo doesn't add programs in Additional Folders if they're on external USB drives

Post by ilike2burnthing »

Ok so scratch that.

I turned on debugging to get verbose logs (didn't realise that was an option before), and it showed the reason for rejecting them was 'installer/uninstaller', despite them not being installers, and the same programs show up fine when symlinked.

After a bit of testing, it turns out that they're being rejected because the root folder is called 'Installers'. Same thing happens if 'Installer' is used, and if a folder with those names is on an internal drive.

Is this intended behaviour or should I email the logs?

Kyle_Katarn
Site Admin
Posts: 1411
Joined: Sun Jul 03, 2011 8:13 pm

Re: SUMo doesn't add programs in Additional Folders if they're on external USB drives

Post by Kyle_Katarn »

ilike2burnthing wrote:
Thu Apr 23, 2020 2:15 pm
Ok so scratch that.

I turned on debugging to get verbose logs (didn't realise that was an option before), and it showed the reason for rejecting them was 'installer/uninstaller', despite them not being installers, and the same programs show up fine when symlinked.

After a bit of testing, it turns out that they're being rejected because the root folder is called 'Installers'. Same thing happens if 'Installer' is used, and if a folder with those names is on an internal drive.

Is this intended behaviour or should I email the logs?
It's as per design. No problem on SUMo side.


Kyle_Katarn
Site Admin
Posts: 1411
Joined: Sun Jul 03, 2011 8:13 pm

Re: [Resolved] SUMo doesn't add programs in folders with 'Installer' in their name

Post by Kyle_Katarn »

You're welcome :)

Post Reply